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Adaptive equalization is an important tool for today’s receivers. It is required by 
standards such as IEEE 802.16e (Mobile WiMAX™). Adaptive equalization is also 
useful for analyzing signals as it allows you to remove propagation effects from 
measurements and separates linear errors from non-linear errors. Determining 
whether your errors are linear or non-linear can provide useful troubleshooting 
information in and of itself. Adaptive equalization is a useful tool for identifying 
linear errors.

Linear errors include:
 • Group delay distortion
 • Frequency response errors (tilt, ripple)
 • Refl ections or multi-path distortion from IQ modulated signals
 • DSP errors in miscoded bits, or incorrect fi lter coeffi cients

Non-linear errors include:
 • Noise
 • Spectral regrowth or adjacent channel interference
 • Intermodulation
 • Spurs
 • Harmonic distortion

The most common types of equalizers are feed-forward and decision feedback. 
Figure 1, below, shows the process that each of these equalizers uses to com-
pute the fi lter coeffi cients. 

Feed-forward equalization uses an equalization fi lter, before applying any other 
static measurement fi lters that are in place. The signal is then demodulated and 
measured. After measurement, the equalization fi lter is modifi ed to adjust for 
additional changes.  

In decision feedback equalization, the static measurement fi lters are applied 
fi rst, then combined with the output of the previous cycle. In this method, the 
modulator will ideally output a noise-free signal, so that the equalization process 
itself does not add any additional noise to the signal.

Figure 1.  Predominant types of equalization.
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There are also two types of equalizer training techniques: one uses training 
sequences embedded in the signal, and the other, called blind equalization, does 
not. Figure 2, below, shows the block diagram representation for these equalizer 
training techniques. While blind equalization works without any prior knowledge 
of the signal, it can be slow to converge if a lot of bit errors are present. Slow 
convergence makes the equalizer less responsive to rapidly changing channel 
conditions. Most equalizers use training sequences. The signal must include this 
sequence, and throughput is therefore reduced. The trade-off is that the equalizer 
is able to converge quickly, even in the presence of many bit errors.

Figure 2.  Equalizer training techniques.

The 89600 VSA software uses a feed-forward equalizer type, with a blind 
equalization training technique. This provides a universal equalizer setup that 
accommodates a wide range of signal types. This demonstration guide discusses 
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 • Option AYA computes Channel Frequency Response (explained in more  
  detail below) by comparing the IQ Meas Time and IQ Ref Time data, while the  
  formats listed above compute it from a training sequence, the preamble/data.
 • Option AYA uses averaging when computing the equalizer frequency response.  
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 • Option AYA allows the equalization fi lter to be disengaged. The other format  
  options cannot be disabled.

Further information about these topics can be found in the Help section of the 
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Table 1, below, describes the minimum hardware requirements for running the 
89600 VSA software.

Table 1. System requirements

Characteristic Microsoft® Windows® XP 
Professional

Microsoft® Windows® 
Vista Business, Enterprise, 
or Ultimate

CPU 600 MHz Pentium® or AMD-K6
> 600 MHz  (>2 GHz recommended)

1 GHz 32-bit (x86) or 64-bit
(x64) (>2 GHz recommended)

Empty slots 
(desktop)

1 PCI-bus slot (Two recommended 
– VXI hardware only)

1 PCI-bus slot (Two 
recommended – VXI 
hardware only)

Empty slots 
(laptop)

1 CardBus Type II slot (Integrated 
FireWire® recommended for VXI 
hardware only)

1 CardBus Type II slot 
(Integrated FireWire® 
recommended for VXI 
hardware only)

RAM 512 MB  (1 GB recommended) 1 GB (2 GB recommended)
Video RAM 4 MB (16 MB recommended) 128 MB (512 MB 

recommended)
Hard disk 512 MB available 512 MB available
Additional 
drives

CD-ROM to load the software; 
license transfer requires a 3.5 
inch fl oppy disk drive, network 
access, or USB memory stick

CD-ROM to load the software; 
license transfer requires a 
3.5 inch fl oppy disk drive, 
network access, or USB 
memory stick

Interface 
support

LAN, GPIB, USB, or FireWire1 
interface (VXI HW only)  

LAN, GPIB, USB, or FireWire1 
interface (VXI HW only)  

Table 2, below, describes the 89600 VSA software requirements to use this dem-
onstration guide. If you do not already have a copy of the software, a free trial 
version can be downloaded at www.agilent.com/fi nd/89600.

Table 2.  Software requirements

Version 89600 version 1.0 or higher (89601A, 89601AN, 89601N12)  
– Note:  substantial improvements to the options listed below 
have occurred since  version 1.0, and customers are encouraged 
to use the latest version. Existing 89600 VSA customers can 
order the 89601AS/ASN software update subscription service to 
upgrade to the latest version. 

Options
 • 200
 • 300

 • AYA

(89601A, 89601AN only)
Basic vector signal analysis
Hardware connectivity 
(required only if measurement hardware will be used)
Vector modulation analysis

System 
Requirements

1. For a list of supported IEEE-1394 (FireWire) interfaces, visit www.agilent.com/fi nd/89600 and  
 search the FAQ’s for information on “What type of IEEE-1394 interface can I use in my computer  
 to connect to the 89600S VXI hardware?”
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This note is written as a guide to using the 89600 Series VSA software for 
making adaptive equalization measurements. More information about the topics 
discussed can be found in the help text documentation included with the 
software by clicking the Help button on the main toolbar menu.

Recall sample signal

The instructions listed in Table 3 recall the signal used in the fi rst portion of this 
demonstration. Your display should look similar to Figure 3. This is a QPSK signal 
with a center frequency of 5 MHz and a nominal span of 156.25 kHz.

Table 3.  Recall recorded sample signal

Instructions Toolbar menus
Preset the software File > Preset > Preset All

Note: Using Preset All will cause all saved 
user state information to be lost. If this is 
a concern, save the current state before 
using Preset All.
Click File > Save > Setup

Go to the default signal directory 
(C:\Program Files\Agilent\89600VSA\
Help\Signals)

File > Recall > Recall Recording

Select the Qpsk.dat signal Select Qpsk.dat
Click Open

Start the measurement Click  ►  (toolbar, left side)

Figure 3.  Recalled recorded signal.

For best results, the center frequency, span, range, etc. should be set to their 
correct values for the signal you are using.

Setup
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To work with adaptive equalization, the analyzer must be in digital demodulation 
mode. Table 4, below, describes the method for setting up digital demodulation, 
and Figure 4 shows the resulting display.

Table 4.  Setting up digital demodulation

Instructions Toolbar menus
Select demodulation type MeasSetup > Demodulator > Digital Demodulation
Change display setting Display > Layout > Grid 2x2
Set up the demodulator MeasSetup > Demod Properties

Click on the Format tab
Set the format parameters Click the drop-down arrow for the Format and select QPSK

In the Symbol Rate box type 50 and select kHz from 
the drop down box

Set the search parameters Click on the Search tab
Uncheck the box next to Pulse Search

Figure 4. Digital demodulation for Qpsk.dat signal.

Starting Digital 
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Filter parameters

Table 5 describes turning off the measurement fi lter for the Qpsk.dat signal, 
and replacing it with the equalization fi lter. Figure 5 shows the resulting display. 
The 89600 VSA software provides several standard measurement and reference 
fi lters that can be used with your signals. The current correct measurement 
fi lter for the Qpsk.dat signal is a Root Raised Cosine or Nyquist fi lter. This fi lter 
produces excellent EVM results. However, for the purpose of this demonstration, 
we will replace the standard fi lter with the adaptive equalizer.

Figure 5. Qpsk.dat signal with measurement fi lter turned off.

Figure 6 shows the Digital Demodulation Properties window. The lower half of 
this display is for the equalization fi lter. Detailed descriptions for each of these 
parameters can be found on the following pages. To reset the equalization fi lter 
at any time, check the Reset Equalizer button.

Figure 6.  Setting equalization fi lter parameters for Qpsk.dat signal.

Adaptive 
Equalization
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Filter length
The Filter Length parameter sets the fi lter length for the equalizer in terms of 
symbols. The shorter the fi lter length, the faster the fi lter will converge. Filter 
length should be kept as short as possible for your measurement needs. If you 
are measuring directly at the transmitter, fi lter lengths as short as a few sym-
bols can be used. However, if you are measuring at the receiver and multi-path 
effects are present, much longer fi lter parameters may be needed to compen-
sate for delays in the signal path. The preset value of 21 symbols, which is used 
in this demonstration, is a good starting point. It can be adjusted depending on 
your needs.

Convergence
The Convergence parameter sets the size between steps of the fi lter coeffi -
cients when the fi lter is being shaped. In practicality, this dictates how quickly 
the fi lter will converge to the correct shape. Values that are too small cause 
the fi lter to converge very slowly, making the wait time for the fi lter impractical. 
However, if values are too large you will not be able to minimize EVM error. 
The best approach is to start with a larger value and step down to reasonable 
values. Typically, a good convergence value is approximately 1E-7. Figure 7, 
below, shows the resulting ‘blow up’ effect of a convergence value set to 1E-5, 
which is too large. This same effect will occur even when using a reasonable 
convergence value if the equalizer is left to continuously run for an extended 
amount of time (10+ minutes for this signal with the given parameters). This is 
a phenomenon that occurs with all blind equalization fi lters, as the fi lter is not 
using a training sequence, and begins to ‘over-correct’ the fi lter coeffi cients.

Figure 7. Qpsk.dat signal with convergence value set to 1E-5.  Note that the same ‘blow up’ effect 
occurs if the equalizer runs for a long period of time.
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Adaptive
The Adaptive parameter determines whether or not the adaptive equalizer is 
actively computing new values for the fi lter. If the Run selection is chosen, new 
values are actively being computed, and then applied to the fi lter. In this manner, 
the fi lter is continuously adapting to changes it “sees” in the output. If the Hold 
selection is chosen, the last computed fi lter coeffi cients are being used in the 
equalization fi lter, but new values are not being computed.

Table 5.  Turning on the adaptive equalizer

Instructions Toolbar menus
Turn off the Measurement Filter. 
Note that the constellation is now 
poorly formed.

Click the Filter tab
Click the drop-down arrow for Measurement 
Filter and select Off

Turn on the Equalization Filter Click the Compensate tab
Click in the box next to Equalization Filter 

Set the Equalization Filter parameters In the Filter Length box type 21
In the Convergence box type 1E-7
Click the drop-down arrow for Adaptive and 
select Run
Click the Reset Equalizer button

Figure 8 and Figure 9, on page 11, are screen shots of the equalizer at two different 
times. Figure 8 was taken immediately after the equalizer began running, while 
Figure 9 was taken a little over a minute later. In these fi gures, Trace C shows 
the error vector time display, which is error vector magnitude (EVM) vs. time, 
and Trace D shows the EVM error, along with several other measurements. 
Notice that in Figure 8 the error magnitude is larger than that of Figure 9, both 
graphically in Trace C and the numeric EVM measurement in the Error Summary 
Trace of Trace D. You can observe this phenomenon by clicking the Reset Equalizer
button again and watching Trace C. Over time you will see the effects of the 
adaptive equalizer take effect and signifi cantly decrease this error. You should 
also notice in these fi gures that ‘EQ’ appears in the upper right hand corner of 
each display. This indicates that the equalization fi lter is active.
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Figure 8.  Note the high EVM vs. Time in Trace C (upper right) at start of equalization.

Figure 9.  Low EVM vs. Time after allowing equalizer to run (Trace C, upper right).
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Trace displays

There are several trace displays that can be used to view the fi ltering that the 
adaptive equalizer provides. The steps to view these traces are outlined in Table 
6. The data from these traces can be captured for export to a spreadsheet by 
selecting the trace (by left clicking anywhere in the trace), then clicking Edit > 
Copy Trace Data. Use this to create your own fi lters by copying the equalizer 
impulse response and using its coeffi cients.

Channel frequency response
The Ch Frequency Response display shows the channel frequency response 
of the channel being measured. It is computed by taking the inverse of the 
of the equalization fi lter’s frequency response. It is typically used to evaluate 
transmitter and/or receiver multi-path effects. Trace B in Figure 11 gives an 
example of the channel frequency response.

Equalizer impulse response
The Eq Impulse Response display shows the time domain response of the 
equalization fi lter. Initially, or on reset, the Eq Impulse Response display shows a 
unit impulse response. Once the fi lter has been turned on, however, the adaptive 
equalizer modifi es the coeffi cients and the impulse response is changed to 
“clean up” the signal.  

Table 6.  Equalization displays

Instructions Toolbar menus
Channel Frequency 
Response display

Double click the Trace B title (B: Ch1 Spectrum)
Select Channel 1 from the Type menu
Select Ch Frequency Response from the Data menu  
Click OK

Symbol Table display Double click the Trace C title (C: Ch1 QPSK Err Vect Time)
Select Channel 1 from the Type menu
Select Syms/Errs from the Data menu
Click OK

Equalizer Impulse 
Response display

Double click the Trace D title (D: Ch1 QPSK Syms/Errs)
Select Channel 1 from the Type menu
Select Eq Impulse Response from the Data menu. 
Click OK

Reset the equalization fi lter Click the Reset Equalizer button
Auto scale Trace B Right click anywhere in Trace B

Select Y Auto Scale
Auto scale Trace D Right click anywhere in Trace D

Select Y Auto Scale
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Figure 10 and Figure 11 show several different stages of the equalizer response 
as it modifi es the fi lter coeffi cients. Figure 10 shows the initial response of the 
equalization fi lter when it fi rst starts running. Figure 11 shows the equalizer’s 
response after a little over a minute, which is approximately the optimal value.

Figure 10.  Beginning of digital demodulation for Qpsk.dat signal. Note that the equalizer channel 
frequency response (trace B, lower left) is only slightly varied from its initial fl at response.

Figure 11.  Digital demodulation for Qpsk.dat signal after about a minute, with excellent EVM (see 
Trace C table), and well-formed channel frequency response.
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Making measurements on digitally modulated, burst, or hopping signals can be 
diffi cult. Agilent’s 89600 VSA software can help aid you in troubleshooting your 
signals so you can make your measurements quickly and easily. The adaptive 
equalizer that is a standard feature in the vector modulation analysis Option 
AYA is an invaluable tool to help measure and troubleshoot your signal. With 
preset modes, and table summaries of common measurements, the 89600 VSA 
software is the perfect tool for any designer wanting a competitive edge in 
getting their product to market faster.

Publication title Publication 
type

Publication 
number

89600 Series Vector Signal Analysis Technical Overview 5989-1679EN
89600 Series Vector Signal Analysis
89601A/89601AN/89601N12

Data Sheet 5989-1786EN

89600 Vector Signal Analyzer 
demo software

CD 5980-1989E

Equalization Techniques and OFDM 
Troubleshooting for Wireless LANs

Application Note 5988-9440EN

Hardware Measurement Platforms for 
the Agilent 89600 Series Vector Signal 
Analysis Software

Data Sheet 5989-1753EN

89600 Series Vector Signal Analyzers, VXI Confi guration Guide 5989-9350E
89607A WLAN Test Suite Software Technical Overview 5988-9574EN

For additional information, visit:

www.agilent.com/fi nd/89600

Summary

Related Literature

Web Resources
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Ordering 
Information

89601A or
89601AN

Vector signal analysis software 89601A (node-locked license) 
also includes 1 year of software update subscription service. 
89601AN (fl oating license) has a software update subscription 
service available for order separately.

Options
• -200
• -300
• -AYA
• -BHD
• -B7N
• -B7T
• -B7U
• -B7W
• -B7X
• -B7R
• -B7S
• -B7Y
• -B7Z
• -BHA
• -BHB
• -BHC
• -105
• -106

Options 200 and 300 are required
Basic vector signal analysis software
Hardware connectivity
Flexible modulation analysis
LTE modulation analysis
3G modulation analysis bundle
cdma2000®/1xEV-DV modulation analysis
W-CDMA/HSDPA modulation analysis
1xEV-DO modulation analysis
TD-SCDMA modulation analysis
WLAN modulation analysis
IEEE 802.16-2004 OFDM modulation analysis
IEEE 802.16 OFDMA modulation analysis
IEEE 802.11n modulation analysis
TETRA modulation analysis and test
MB-OFDM ultra-wideband modulation analysis
RFID modulation analysis
Dynamic link to EEsof/ADS
Dynamic link to The MathWorks Simulink Model-Based Design

89601N12 Vector signal analysis software, 12-month limited-term package 
fl oating license for one server; includes 1-year software update 
subscription.

Options

    89601N12-801

Required. Multiple 801 options may be ordered per server. 
For multiple servers, order additional 89601N12.

Twelve-month fl oating license software package including VSA 
software Options -200, -300, -105, -106, -AYA, -B7N, -B7R, -B7S, 
-B7Y, -B7Z, -BHA, -BHB, -BHC, -BHD

89601AS Additional software update subscription service
Notes Twelve-month minimum required. Twenty-four-month maximum 

coverage, total. 1-year is provided. Model 89601AS is available for 
upgrade or renewal orders only. To order, choose the number of 
months desired, and order Option 89601AS-0xx, where xx is 12 to 
24, corresponding to the number of months of coverage desired.
See www.agilent.com/fi nd/89600 and click “Software Update 
Subscription Service” for descriptions of actual product and option 
structure.

89601ASN Software update subscription service for one server (fl oating license)
Notes Twelve-month minimum required on new standalone or renewal 

89601ASN orders. Twenty-four month maximum coverage, total. 
To order, choose the number of months desired, and order Option 
89601ASN-0xx, where xx is 12 to 24, corresponding to the number 
of months of coverage desired. Choose an option quantity which 
corresponds to the number of Option 200s on the server. Order a 
separate 89601ASN for each server.
See www.agilent.com/fi nd/89600 and click “Software Update 
Subscription Service” for descriptions of actual product and option 
structure.
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